<!doctype html>
<!--[if lt IE 7 ]> <html lang="en" class="no-js ie6"> <![endif]-->
<!--[if IE 7 ]>    <html lang="en" class="no-js ie7"> <![endif]-->
<!--[if IE 8 ]>    <html lang="en" class="no-js ie8"> <![endif]-->
<!--[if IE 9 ]>    <html lang="en" class="no-js ie9"> <![endif]-->
<!--[if (gt IE 9)|!(IE)]><!--> <html lang="en" class="no-js"> <!--<![endif]-->
<head>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

	<title> - by Common Sense Mike - Newsvine</title>

	<meta name="viewport" content="width=device-width, initial-scale=1.0">
	<meta http-equiv="Content-Language" content="en" />

<meta name="title" content=" - by Common Sense Mike - Newsvine" />
<meta name="description" content="People have a lot to learn about Libertarians today. We aren't the fringe crackpots that the media portrays us to be.  " />
<meta name="author" content="Common Sense Mike" />
<meta name="canonical" content="https://faminchin.newsvine.com/_news/2017/02/24/36988982-" />
<meta name="section" content="{&quot;domainName&quot;:&quot;faminchin&quot;,&quot;displayName&quot;:&quot;Common Sense Mike&quot;,&quot;avatar&quot;:&quot;https:\/\/m.newsvine.com\/servista\/imagesizer?file=http3A2F2Fwww.newsvine.com2F_vine2Fimages2Fav2F120x1202Ffaminchin-2012856092.jpg&amp;width=30&quot;,&quot;url&quot;:&quot;https:\/\/faminchin.newsvine.com\/&quot;,&quot;type&quot;:&quot;user&quot;,&quot;membership&quot;:&quot;&quot;,&quot;memberSince&quot;:1220464380,&quot;numSeeds&quot;:&quot;66&quot;,&quot;numComments&quot;:&quot;6442&quot;,&quot;numArticles&quot;:&quot;31&quot;,&quot;watchers&quot;:34}" />
<meta name="trackData" content="{&quot;section&quot;:&quot;politics&quot;,&quot;sitePageId&quot;:36988982,&quot;headline&quot;:&quot;&quot;,&quot;pageSource&quot;:&quot;Common Sense Mike&quot;,&quot;typeName&quot;:&quot;video&quot;,&quot;byline&quot;:&quot;faminchin&quot;,&quot;tags&quot;:[&quot;trump&quot;,&quot;clinton&quot;,&quot;politics&quot;,&quot;obama&quot;,&quot;republican&quot;,&quot;democrat&quot;,&quot;libertarian&quot;],&quot;seedSource&quot;:&quot;&quot;}" />
<meta name="jenga-session-config" content="{&quot;when_to_init&quot;:&quot;asap&quot;, &quot;load_pers&quot;:&quot;1&quot;}" />
<meta name="server" content="web03" />
<meta name="cip" content="23.220.148.78" />
<meta name="date" content="February 24, 2017, 5:00 pm" />
<meta name="userDomain" content="" />
<meta name="contentId" content="36988982" />
<meta property="og:image" content="https://i.ytimg.com/vi/BreSsmqYmPA/0.jpg" />
<meta property="og:url" content="https://faminchin.newsvine.com/_news/2017/02/24/36988982-" />
<meta property="og:type" content="article" />
<meta property="og:title" content="" />
<meta property="og:description" content="People have a lot to learn about Libertarians today. We aren&#039;t the fringe crackpots that the media portrays us to be." />
<meta property="nv:contentId" content="36988982" />
<meta property="nv:contentType" content="n" />
<meta property="og:site_name" content="Newsvine" />
<link class="cpk_remote" rel="stylesheet" type="text/css" href="https://lib.newsvine.com/chrome/topper/css_static/sprite.css?v=51659" />
<script class="cpk_remote" language="javascript" type="text/javascript" src="//ajax.googleapis.com/ajax/libs/jquery/1.8.2/jquery.min.js"></script>
<script class="cpk_remote" language="javascript" type="text/javascript" src="//nvg.newsvine.com/trackingService/trackingService.min.js"></script>
<script class="cpk_remote" language="javascript" type="text/javascript" src="//assets.adobedtm.com/cd771b0aa897f931a306d7ab6af0d448836b5fd1/satelliteLib-b88fe1bde62daf00f8b0c5f12e4c0827045b0cf2.js"></script>
<script class="cpk_remote" language="javascript" type="text/javascript" src="//secure.newsvine.com/_util/tiny_mce/production/tinymce.min.js"></script>
<link class="cpk_static" rel="stylesheet" type="text/css" href="//secure.newsvine.com/_static/css/ad4b93756a64281abe96651ab3ffc3e4151f0770.css?v=51659" />
<script class="cpk_static" language="javascript" type="text/javascript" src="//secure.newsvine.com/_static/js/fce50ff34e9fc7886bef249853127d58a9616984.js?v=51659"></script>
<link class="cpk_dynamic" rel="stylesheet" type="text/css" href="//secure.newsvine.com/_static/css/3df859e03dad7ad892d4a34a5d4b27d7a39b87cd.css?v=51659" />
<script class="cpk_dynamic" language="javascript" type="text/javascript" src="//secure.newsvine.com/_static/js/fb241194bce3c423fb23d5bc04fc7280efb9b6a3.js?v=51659"></script>
		<style type="text/css">@font-face{font-family:'clarendonweb';src:url('//lib.newsvine.com/fonts/clarendon/clarendon-medium.eot');src:url('lib.newsvine.com/fonts/clarendon/clarendon-medium.eot?#iefix')format('embedded-opentype'),url('//lib.newsvine.com/fonts/clarendon/clarendon-medium.woff')format('woff');font-weight:normal;font-style:normal;}@font-face{font-family:'proximanova';src:url('//lib.newsvine.com/fonts/proximanova.eot');src:url('//lib.newsvine.com/fonts/proximanova.eot?#iefix')format('embedded-opentype'),url('//lib.newsvine.com/fonts/proximanova.woff')format('woff'),url('//lib.newsvine.com/fonts/proximanova.ttf')format('truetype'),url('//lib.newsvine.com/fonts/proximanova.svg#proximanova')format('svg');font-weight:normal;font-style:normal;}@font-face{font-family:'proximanova';src:url('//lib.newsvine.com/fonts/proximanova-italic.eot');src:url('//lib.newsvine.com/fonts/proximanova-italic.eot?#iefix')format('embedded-opentype'),url('//lib.newsvine.com/fonts/proximanova-italic.woff')format('woff'),url('//lib.newsvine.com/fonts/proximanova-italic.ttf')format('truetype'),url('//lib.newsvine.com/fonts/proximanova-italic.svg#proximanovaitalic')format('svg');font-weight:normal;font-style:italic;}@font-face{font-family:'proximanova';src:url('//lib.newsvine.com/fonts/proximanova-bold.eot');src:url('//lib.newsvine.com/fonts/proximanova-bold.eot?#iefix')format('embedded-opentype'),url('//lib.newsvine.com/fonts/proximanova-bold.woff')format('woff'),url('//lib.newsvine.com/fonts/proximanova-bold.ttf')format('truetype'),url('//lib.newsvine.com/fonts/proximanova-bold.svg#proximanovabold')format('svg');font-weight:bold;font-style:normal;}@font-face{font-family:'proximanova';src:url('//lib.newsvine.com/fonts/proximanova-bold-italic.woff')format('woff'),url('//lib.newsvine.com/fonts/proximanova-bold-italic.ttf')format('truetype'),url('//lib.newsvine.com/fonts/proximanova-bold-italic.svg#proximanovabolditalic')format('svg');font-weight:bold;font-style:italic;}</style>
					<!--[if IE 7 ]>
				<link rel="stylesheet" href="https://lib.newsvine.com/chrome/topper/ie.css" type="text/css"/>
			<![endif]-->

			<!--[if IE 8 ]>
				<link rel="stylesheet" href="https://lib.newsvine.com/chrome/topper/ie.css" type="text/css"/>
			<![endif]-->

			<!--[if IE 9 ]>
				<link rel="stylesheet" href="https://lib.newsvine.com/chrome/topper/ie.css" type="text/css"/>
			<![endif]-->
		</head><body class="c-desktop">
<script src="//ssl.nbcnews.com/id/51738311" type="text/javascript"></script><script language="javascript" type="text/javascript">document.write('<div class="pokeDiv" style="display:none;"><img id="poke" src="https://log.newsvine.com/poke.gif?x=0|26&amp;get=%2F_news%2F2017%2F02%2F24%2F36988982-&amp;rand=1235563612&amp;do=newsvine.com&amp;ad=" alt="" width="0" height="0" /></div>');</script>
<noscript><div class="pokeDiv" style="display:none;"><img id="poke" src="https://log.newsvine.com/poke.gif?x=0|26&amp;get=%2F_news%2F2017%2F02%2F24%2F36988982-&amp;rand=1235563612&amp;do=newsvine.com&amp;ad=" alt="" width="0" height="0" /></div></noscript>
<a name="top"></a><div class="chrome_template chrome_topper_ChromeTemplate">
<div class="chrome_header">
<div class=" topper_header_Branding"><a href="http://www.newsvine.com" class="c-home"><span class="c-logo"></span><span>Newsvine</span></a><div class="j-zinger"><div class=" j_zinger2_menu" data-mode="menu" data-zinger="{&quot;newsvine_options&quot;:{&quot;registerTitle&quot;:&quot;Register&quot;}}"></div></div><div class=" topper_user_UserNav"><div class="j-touchnav c-touchnav"><div class="c-loggedin j-loggedin c-hide">	
		<ul class="c-header-nav">

						<li class="c-nav-publish"><div class=" j_publish_menu" data-access="loggedin"><script type="text/html" class="template_menu">

	<a href="{{url_article}}" class="b-target">Publish</a>

	<ul class="b-menu c-dropmenu-full">
		<li class="j-blog-post" style="display:none;"><a href="{{url_blog}}" class="c-icon">Blog Post</a></li>
		<li><a href="{{url_article}}" class="c-icon c-article j-article">Write Article</a></li>
		<li><a href="{{url_seed}}" class="c-icon c-seed j_seed_link">Seed Link</a></li>
		<li><a href="{{url_photo}}" class="j-photo-post c-icon c-photo">Post Photo</a></li>
		<li><a href="{{url_video}}" class="j-video-post c-icon c-video">Post Video</a></li>
		<li><a href="{{url_edit}}" class="c-icon c-article">Edit Content</a></li>
	</ul>

</script></div></li>
				<li class="j-nations c-nav-nations" data-add-class="topnav" data-has-triangle="0" data-force-bottom="1" data-align-trigger-left="1">
					<a href="https://www.newsvine.com/_tps/_group/nations">Nations <span class="c-touchhide">&#9662;</span></a>
					<div class="j_popover_content j-nations-content ">
						<ul class="c-dropmenu-full">
							<li><a href="https://www.newsvine.com/_tps/_group/nations" class="c-icon c-search">Manage / Find</a></li>
							<li><a href="https://www.newsvine.com/_tps/_group/create" class="c-icon">Create</a></li>
							<li><a href="https://www.newsvine.com/_tps/_greenout" class="c-icon">Recruit new members</a></li>
						</ul>
						<div data-popover-content-widget="j_group_picker"></div>
					</div>
				</li>
				<li id="activity_menu" class="j-activity c-nav-activity" data-add-class="activity-nav" data-has-triangle="0" data-force-bottom="1">
					<a href="https://www.newsvine.com/_tps/_activity">Activity<span class="c-activity-count j-activity-count" style="display: none;"></span> <span class="c-touchhide">&#9662;</span></a>
					<div class="j_popover_content" data-popover-content-widget="j_user_ct_activityMenu"></div>
				</li>
				<li class="j-inbox c-nav-inbox" data-add-class="activity-nav" data-has-triangle="0" data-force-bottom="1">
					<a href="https://www.newsvine.com/_tps/_inbox">Inbox<span class="c-inbox-count j-inbox-count" style="display: none;"></span> <span class="c-touchhide">&#9662;</span></a>
					<div class="j_popover_content" data-popover-content-widget="topper_user_EventTrackerInvites"></div>
				</li>
								<li class="j-help c-nav-help" data-add-class="topnav" data-has-triangle="0"
			data-prevent-right="1" data-prevent-top="1" data-prevent-left="1" data-align-trigger-left="1">
			<a href="https://www.newsvine.com/_tps/_about/contact">Help <span class="c-touchhide">&#9662;</span></a>
			<div class="j_popover_content c-publish-nav c-noicon" >
				<ul class="c-dropmenu-full">
					<li class="c-nav-tour"><a href="https://www.newsvine.com/_tps/_tour">Quick Tour</a></li>
					<li><a href="http://support.newsvine.com/kb/getting-started" target="_blank">Getting Started</a></li>
					<li><a href="http://support.newsvine.com/kb" target="_blank">Knowledge Base</a></li>
					<li><a href="http://support.newsvine.com/discussion/new" target="_blank">Ask a Question</a></li>
					<li><a href="https://www.newsvine.com/_tps/_about/contact">Contact Newsvine</a></li>
					<li><a href="https://www.newsvine.com/_tps/_about/contact?subjectList=Report a Bug" class="j-report-bug">Report a Bug</a></li>
					<li><a href="http://blog.newsvine.com">Newsvine Blog</a></li>
					<li class="c-coh"><a href="https://www.newsvine.com/_tps/about/code">Code of Honor</a></li>
				</ul>
			</div>
		</li>
							<li class="c-nav-about c-touch-show"><a href="https://www.newsvine.com/_tps/_about/contact">About</a></li>
			<li class="c-nav-search-link c-touch-show"><a href="https://www.newsvine.com/_tps/_search">Search</a></li>
			<li class="c-nav-search c-touch-hide">		<form class="j-search-form" action="/_tps/_search" method="get">
			<input type="text" name="q" value="" placeholder="Search" class="j-search c-search-site" />
			<input type="hidden" value="Search" name="sa">
			<input type="hidden" value="012943277593349087480:xx9wfuef0se" name="cx">
			<input type="hidden" value="FORID:11" name="cof">
		</form>
	</li>

		</ul>

	</div><div class="c-loggedout j-loggedout c-hide">
		<ul class="c-header-nav">
			<li class="c-nav-signup"><a href="https://secure.newsvine.com/_tps/accounts/register" class="c-plate">Sign Up</a></li>
					<li class="j-help c-nav-help" data-add-class="topnav" data-has-triangle="0"
			data-prevent-right="1" data-prevent-top="1" data-prevent-left="1" data-align-trigger-left="1">
			<a href="https://www.newsvine.com/_tps/_about/contact">Help <span class="c-touchhide">&#9662;</span></a>
			<div class="j_popover_content c-publish-nav c-noicon" >
				<ul class="c-dropmenu-full">
					<li class="c-nav-tour"><a href="https://www.newsvine.com/_tps/_tour">Quick Tour</a></li>
					<li><a href="http://support.newsvine.com/kb/getting-started" target="_blank">Getting Started</a></li>
					<li><a href="http://support.newsvine.com/kb" target="_blank">Knowledge Base</a></li>
					<li><a href="http://support.newsvine.com/discussion/new" target="_blank">Ask a Question</a></li>
					<li><a href="https://www.newsvine.com/_tps/_about/contact">Contact Newsvine</a></li>
					<li><a href="https://www.newsvine.com/_tps/_about/contact?subjectList=Report a Bug" class="j-report-bug">Report a Bug</a></li>
					<li><a href="http://blog.newsvine.com">Newsvine Blog</a></li>
					<li class="c-coh"><a href="https://www.newsvine.com/_tps/about/code">Code of Honor</a></li>
				</ul>
			</div>
		</li>
				<li class="c-nav-tour"><a href="https://www.newsvine.com/_tps/_tour">Quick Tour</a></li>
			<li class="c-nav-search">		<form class="j-search-form" action="/_tps/_search" method="get">
			<input type="text" name="q" value="" placeholder="Search" class="j-search c-search-site" />
			<input type="hidden" value="Search" name="sa">
			<input type="hidden" value="012943277593349087480:xx9wfuef0se" name="cx">
			<input type="hidden" value="FORID:11" name="cof">
		</form>
	</li>
		</ul>

	</div></div></div><div class="j-takeout c-touchdown"><button class="c-button">Menu</button></div></div><div class="topper_header_SectionBar elliott_section_SectionPrinter topper_header_AuthorBar"><div class="c-section-info">
	<a href="" class="j_flag_style j_author_card j-author-avatar c-section-avatar c-author-avatar"
		rel="twipsy" title="Open Card" 
		 
		 
		data-avatar="https://m.newsvine.com/servista/imagesizer?file=http3A2F2Fwww.newsvine.com2F_vine2Fimages2Fav2F120x1202Ffaminchin-2012856092.jpg&amp;width=80"
		data-domain-name="faminchin"
		data-display-name="Common Sense Mike">
		<img src="https://m.newsvine.com/servista/imagesizer?file=http3A2F2Fwww.newsvine.com2F_vine2Fimages2Fav2F120x1202Ffaminchin-2012856092.jpg&amp;width=80" height="80" width="80" />
	</a>
		<h1>
			<a href="https://faminchin.newsvine.com/" rel="twipsy" title="View Common Sense Mike's Column"  data-placement="bottom">
				Common Sense Mike			</a>
		</h1>
	
	<ul class="c-author-grouplist j-author-grouplist">
		<li>
	<a href="https://believersonthevine.newsvine.com/" class="j_flag_style j_group_card j-group-avatar c-section-avatar c-group-avatar"
		data-group="{&quot;domainName&quot;:&quot;believersonthevine&quot;,&quot;displayName&quot;:&quot;Believers On The Vine&quot;,&quot;avatar&quot;:&quot;https:\/\/m.newsvine.com\/servista\/imagesizer?file=faminchinE969C266-213A-B8AD-0EB3-C2294A735F3C.jpg&amp;width=30&quot;,&quot;url&quot;:&quot;https:\/\/believersonthevine.newsvine.com\/&quot;,&quot;type&quot;:&quot;group&quot;,&quot;groupId&quot;:&quot;2733&quot;,&quot;articleCount&quot;:&quot;432&quot;,&quot;seedCount&quot;:&quot;674&quot;,&quot;memberCount&quot;:&quot;104&quot;,&quot;description&quot;:&quot;A group of believers committed to helping one another in further understanding of the gospel, supporting each other in times of trouble and celebrating together successes and victories in Jesus Christ.&quot;,&quot;createDate&quot;:1225257960,&quot;groupType&quot;:&quot;Gated&quot;,&quot;groupTypeId&quot;:&quot;0&quot;,&quot;blessed&quot;:0,&quot;lastPub&quot;:1485833742,&quot;isEnabled&quot;:1}"  
		rel="twipsy"  title="Believers On The Vine"
		 
		data-placement="bottom" 
		data-avatar="https://m.newsvine.com/servista/imagesizer?file=faminchinE969C266-213A-B8AD-0EB3-C2294A735F3C.jpg&amp;width=70"
		data-domain-name="believersonthevine"
		data-display-name="Believers On The Vine">
		<img src="https://m.newsvine.com/servista/imagesizer?file=faminchinE969C266-213A-B8AD-0EB3-C2294A735F3C.jpg&amp;width=70" height="20" width="20" />
	</a>
</li><li>
	<a href="https://christians-corner.newsvine.com/" class="j_flag_style j_group_card j-group-avatar c-section-avatar c-group-avatar"
		data-group="{&quot;domainName&quot;:&quot;christians-corner&quot;,&quot;displayName&quot;:&quot;Christian's Corner&quot;,&quot;avatar&quot;:&quot;https:\/\/secure.newsvine.com\/_vine\/images\/av\/30x30\/group.gif&quot;,&quot;url&quot;:&quot;https:\/\/christians-corner.newsvine.com\/&quot;,&quot;type&quot;:&quot;group&quot;,&quot;groupId&quot;:&quot;2640&quot;,&quot;articleCount&quot;:&quot;728&quot;,&quot;seedCount&quot;:&quot;612&quot;,&quot;memberCount&quot;:&quot;274&quot;,&quot;description&quot;:&quot;This is a place for ALL Christian believers to gather together.  Whether a Fundamentalist or a Theological Liberal, all are welcome here.  \&quot;Where one or more are gathered in His name, there He will be also.\&quot;&quot;,&quot;createDate&quot;:1223238720,&quot;groupType&quot;:&quot;Gated&quot;,&quot;groupTypeId&quot;:&quot;100&quot;,&quot;blessed&quot;:1,&quot;lastPub&quot;:1485833742,&quot;isEnabled&quot;:1}"  
		rel="twipsy"  title="Christian's Corner"
		 
		data-placement="bottom" 
		data-avatar="https://secure.newsvine.com/_vine/images/av/120x120/group.gif"
		data-domain-name="christians-corner"
		data-display-name="Christian's Corner">
		<img src="https://secure.newsvine.com/_vine/images/av/120x120/group.gif" height="20" width="20" />
	</a>
</li><li>
	<a href="https://dasofolde.newsvine.com/" class="j_flag_style j_group_card j-group-avatar c-section-avatar c-group-avatar"
		data-group="{&quot;domainName&quot;:&quot;dasofolde&quot;,&quot;displayName&quot;:&quot;DA's of Olde&quot;,&quot;avatar&quot;:&quot;https:\/\/m.newsvine.com\/servista\/imagesizer?file=rhwengr551603DC-CC23-9B6A-8B1F-D70CC77BB46F.jpg&amp;width=30&quot;,&quot;url&quot;:&quot;https:\/\/dasofolde.newsvine.com\/&quot;,&quot;type&quot;:&quot;group&quot;,&quot;groupId&quot;:&quot;10445&quot;,&quot;articleCount&quot;:&quot;1449&quot;,&quot;seedCount&quot;:&quot;9258&quot;,&quot;memberCount&quot;:&quot;100&quot;,&quot;description&quot;:&quot;The days of Olde are now the present.&quot;,&quot;createDate&quot;:1381752360,&quot;groupType&quot;:&quot;Gated&quot;,&quot;groupTypeId&quot;:&quot;0&quot;,&quot;blessed&quot;:0,&quot;lastPub&quot;:1487962896,&quot;isEnabled&quot;:1}"  
		rel="twipsy"  title="DA's of Olde"
		 
		data-placement="bottom" 
		data-avatar="https://m.newsvine.com/servista/imagesizer?file=rhwengr551603DC-CC23-9B6A-8B1F-D70CC77BB46F.jpg&amp;width=70"
		data-domain-name="dasofolde"
		data-display-name="DA's of Olde">
		<img src="https://m.newsvine.com/servista/imagesizer?file=rhwengr551603DC-CC23-9B6A-8B1F-D70CC77BB46F.jpg&amp;width=70" height="20" width="20" />
	</a>
</li><li>
	<a href="https://iesous.newsvine.com/" class="j_flag_style j_group_card j-group-avatar c-section-avatar c-group-avatar"
		data-group="{&quot;domainName&quot;:&quot;iesous&quot;,&quot;displayName&quot;:&quot;Jesus Name Believers&quot;,&quot;avatar&quot;:&quot;https:\/\/m.newsvine.com\/servista\/imagesizer?file=http3A2F2Fwww.polls.newsvine.com2F_vine2Fimages2Fav2F120x1202Fgroup.gif&amp;width=30&quot;,&quot;url&quot;:&quot;https:\/\/iesous.newsvine.com\/&quot;,&quot;type&quot;:&quot;group&quot;,&quot;groupId&quot;:&quot;3443&quot;,&quot;articleCount&quot;:&quot;100&quot;,&quot;seedCount&quot;:&quot;114&quot;,&quot;memberCount&quot;:&quot;19&quot;,&quot;description&quot;:&quot;Wanting to know the names of God in scripture and there relationship to Jesus Christ. Have an open discussion on the Bible with no disrespect to the way others believe. Must be kind. Studies will be on but not limited to Baptism in Jesus name, Speaking in tongues, and living a holy life.&quot;,&quot;createDate&quot;:1238257500,&quot;groupType&quot;:&quot;Gated&quot;,&quot;groupTypeId&quot;:&quot;0&quot;,&quot;blessed&quot;:0,&quot;lastPub&quot;:1485833742,&quot;isEnabled&quot;:1}"  
		rel="twipsy"  title="Jesus Name Believers"
		 
		data-placement="bottom" 
		data-avatar="https://m.newsvine.com/servista/imagesizer?file=http3A2F2Fwww.polls.newsvine.com2F_vine2Fimages2Fav2F120x1202Fgroup.gif&amp;width=70"
		data-domain-name="iesous"
		data-display-name="Jesus Name Believers">
		<img src="https://m.newsvine.com/servista/imagesizer?file=http3A2F2Fwww.polls.newsvine.com2F_vine2Fimages2Fav2F120x1202Fgroup.gif&amp;width=70" height="20" width="20" />
	</a>
</li><li>
	<a href="https://judeochristians.newsvine.com/" class="j_flag_style j_group_card j-group-avatar c-section-avatar c-group-avatar"
		data-group="{&quot;domainName&quot;:&quot;judeochristians&quot;,&quot;displayName&quot;:&quot;Judeo Christians&quot;,&quot;avatar&quot;:&quot;https:\/\/secure.newsvine.com\/_vine\/images\/av\/30x30\/group.gif&quot;,&quot;url&quot;:&quot;https:\/\/judeochristians.newsvine.com\/&quot;,&quot;type&quot;:&quot;group&quot;,&quot;groupId&quot;:&quot;2896&quot;,&quot;articleCount&quot;:&quot;413&quot;,&quot;seedCount&quot;:&quot;2511&quot;,&quot;memberCount&quot;:&quot;66&quot;,&quot;description&quot;:&quot;Judeo Christians Group is all about the origins of Jewish people, Hebrew language, Jesus Christ, all things Biblical, Jehova, God, the Holy Spirit, presented in a positive environment.  Derogatory comments will not be tolerated.  Please be respectful of our FAITH.  Thank you!&quot;,&quot;createDate&quot;:1228782840,&quot;groupType&quot;:&quot;Gated&quot;,&quot;groupTypeId&quot;:&quot;0&quot;,&quot;blessed&quot;:0,&quot;lastPub&quot;:1485833742,&quot;isEnabled&quot;:1}"  
		rel="twipsy"  title="Judeo Christians"
		 
		data-placement="bottom" 
		data-avatar="https://secure.newsvine.com/_vine/images/av/120x120/group.gif"
		data-domain-name="judeochristians"
		data-display-name="Judeo Christians">
		<img src="https://secure.newsvine.com/_vine/images/av/120x120/group.gif" height="20" width="20" />
	</a>
</li><li>
	<a href="https://logical-thinking.newsvine.com/" class="j_flag_style j_group_card j-group-avatar c-section-avatar c-group-avatar"
		data-group="{&quot;domainName&quot;:&quot;logical-thinking&quot;,&quot;displayName&quot;:&quot;Logic on the Vine&quot;,&quot;avatar&quot;:&quot;https:\/\/secure.newsvine.com\/_vine\/images\/av\/30x30\/group.gif&quot;,&quot;url&quot;:&quot;https:\/\/logical-thinking.newsvine.com\/&quot;,&quot;type&quot;:&quot;group&quot;,&quot;groupId&quot;:&quot;410&quot;,&quot;articleCount&quot;:&quot;518&quot;,&quot;seedCount&quot;:&quot;5716&quot;,&quot;memberCount&quot;:&quot;147&quot;,&quot;description&quot;:&quot;&quot;,&quot;createDate&quot;:1165610760,&quot;groupType&quot;:&quot;Gated&quot;,&quot;groupTypeId&quot;:&quot;0&quot;,&quot;blessed&quot;:0,&quot;lastPub&quot;:1487961235,&quot;isEnabled&quot;:1}"  
		rel="twipsy"  title="Logic on the Vine"
		 
		data-placement="bottom" 
		data-avatar="https://secure.newsvine.com/_vine/images/av/120x120/group.gif"
		data-domain-name="logical-thinking"
		data-display-name="Logic on the Vine">
		<img src="https://secure.newsvine.com/_vine/images/av/120x120/group.gif" height="20" width="20" />
	</a>
</li><li>
	<a href="https://mediaoutrage.newsvine.com/" class="j_flag_style j_group_card j-group-avatar c-section-avatar c-group-avatar"
		data-group="{&quot;domainName&quot;:&quot;mediaoutrage&quot;,&quot;displayName&quot;:&quot;Media Outrage&quot;,&quot;avatar&quot;:&quot;https:\/\/m.newsvine.com\/servista\/imagesizer?file=faminchin13846C1C-3FB2-E997-BF23-F4BF0D3F1E3C.jpg&amp;width=30&quot;,&quot;url&quot;:&quot;https:\/\/mediaoutrage.newsvine.com\/&quot;,&quot;type&quot;:&quot;group&quot;,&quot;groupId&quot;:&quot;2503&quot;,&quot;articleCount&quot;:&quot;1224&quot;,&quot;seedCount&quot;:&quot;11443&quot;,&quot;memberCount&quot;:&quot;481&quot;,&quot;description&quot;:&quot;A group for people to discuss the bias in today's media.  If you feel our media is bias and has an agenda of their own, this is the place to talk about it and post examples.&quot;,&quot;createDate&quot;:1221578400,&quot;groupType&quot;:&quot;Gated&quot;,&quot;groupTypeId&quot;:&quot;0&quot;,&quot;blessed&quot;:0,&quot;lastPub&quot;:1487963955,&quot;isEnabled&quot;:1}"  
		rel="twipsy"  title="Media Outrage"
		 
		data-placement="left" 
		data-avatar="https://m.newsvine.com/servista/imagesizer?file=faminchin13846C1C-3FB2-E997-BF23-F4BF0D3F1E3C.jpg&amp;width=70"
		data-domain-name="mediaoutrage"
		data-display-name="Media Outrage">
		<img src="https://m.newsvine.com/servista/imagesizer?file=faminchin13846C1C-3FB2-E997-BF23-F4BF0D3F1E3C.jpg&amp;width=70" height="20" width="20" />
	</a>
</li><li>
	<a href="https://openminds.newsvine.com/" class="j_flag_style j_group_card j-group-avatar c-section-avatar c-group-avatar"
		data-group="{&quot;domainName&quot;:&quot;openminds&quot;,&quot;displayName&quot;:&quot;Open Minded&quot;,&quot;avatar&quot;:&quot;https:\/\/secure.newsvine.com\/_vine\/images\/av\/30x30\/group.gif&quot;,&quot;url&quot;:&quot;https:\/\/openminds.newsvine.com\/&quot;,&quot;type&quot;:&quot;group&quot;,&quot;groupId&quot;:&quot;135&quot;,&quot;articleCount&quot;:&quot;4588&quot;,&quot;seedCount&quot;:&quot;32294&quot;,&quot;memberCount&quot;:&quot;3122&quot;,&quot;description&quot;:&quot;Regardless of your political affiliation, we all must keep an open mind to the other side.&quot;,&quot;createDate&quot;:1162606140,&quot;groupType&quot;:&quot;Open&quot;,&quot;groupTypeId&quot;:&quot;6&quot;,&quot;blessed&quot;:0,&quot;lastPub&quot;:1487964955,&quot;isEnabled&quot;:1}"  
		rel="twipsy"  title="Open Minded"
		 
		data-placement="left" 
		data-avatar="https://secure.newsvine.com/_vine/images/av/120x120/group.gif"
		data-domain-name="openminds"
		data-display-name="Open Minded">
		<img src="https://secure.newsvine.com/_vine/images/av/120x120/group.gif" height="20" width="20" />
	</a>
</li><li>
	<a href="https://patriotspolitics.newsvine.com/" class="j_flag_style j_group_card j-group-avatar c-section-avatar c-group-avatar"
		data-group="{&quot;domainName&quot;:&quot;patriotspolitics&quot;,&quot;displayName&quot;:&quot;Patriot's Politics&quot;,&quot;avatar&quot;:&quot;https:\/\/secure.newsvine.com\/_vine\/images\/av\/30x30\/group.gif&quot;,&quot;url&quot;:&quot;https:\/\/patriotspolitics.newsvine.com\/&quot;,&quot;type&quot;:&quot;group&quot;,&quot;groupId&quot;:&quot;9047&quot;,&quot;articleCount&quot;:&quot;235&quot;,&quot;seedCount&quot;:&quot;5978&quot;,&quot;memberCount&quot;:&quot;185&quot;,&quot;description&quot;:&quot;Musings on the current state of politics in these United States&quot;,&quot;createDate&quot;:1360261740,&quot;groupType&quot;:&quot;Gated&quot;,&quot;groupTypeId&quot;:&quot;0&quot;,&quot;blessed&quot;:0,&quot;lastPub&quot;:1487972048,&quot;isEnabled&quot;:1}"  
		rel="twipsy"  title="Patriot's Politics"
		 
		data-placement="left" 
		data-avatar="https://secure.newsvine.com/_vine/images/av/120x120/group.gif"
		data-domain-name="patriotspolitics"
		data-display-name="Patriot's Politics">
		<img src="https://secure.newsvine.com/_vine/images/av/120x120/group.gif" height="20" width="20" />
	</a>
</li><li>
	<a href="https://alpha08.newsvine.com/" class="j_flag_style j_group_card j-group-avatar c-section-avatar c-group-avatar"
		data-group="{&quot;domainName&quot;:&quot;alpha08&quot;,&quot;displayName&quot;:&quot;The Big 2008 Election&quot;,&quot;avatar&quot;:&quot;https:\/\/secure.newsvine.com\/_vine\/images\/av\/30x30\/group.gif&quot;,&quot;url&quot;:&quot;https:\/\/alpha08.newsvine.com\/&quot;,&quot;type&quot;:&quot;group&quot;,&quot;groupId&quot;:&quot;568&quot;,&quot;articleCount&quot;:&quot;1583&quot;,&quot;seedCount&quot;:&quot;9416&quot;,&quot;memberCount&quot;:&quot;388&quot;,&quot;description&quot;:&quot;The name kind of explains the group.  It will focus on 2008 election news, possible candidates, strategies, as well as any other election ideas that come to mind.  Just check it out.  I dare you.&quot;,&quot;createDate&quot;:1169237940,&quot;groupType&quot;:&quot;Gated&quot;,&quot;groupTypeId&quot;:&quot;0&quot;,&quot;blessed&quot;:0,&quot;lastPub&quot;:1440304210,&quot;isEnabled&quot;:1}"  
		rel="twipsy"  title="The Big 2008 Election"
		 
		data-placement="left" 
		data-avatar="https://secure.newsvine.com/_vine/images/av/120x120/group.gif"
		data-domain-name="alpha08"
		data-display-name="The Big 2008 Election">
		<img src="https://secure.newsvine.com/_vine/images/av/120x120/group.gif" height="20" width="20" />
	</a>
</li>
	</ul>
<span class="j-author-edit c-author-networks">
			</span>

<p class="c-section-about">
	<a href="/_tps/_author/profile" class="c-button c-icon c-bio c-notext " title="View Author Profile" rel="twipsy" data-placement="top">About</a>
	<span class="c-author-title">
			</span>

	<span class="c-author-stats">
		Articles:&nbsp;31 
		Seeds:&nbsp;66 
		Comments:&nbsp;6442 
		Since:&nbsp;Sep 2008	</span>
</p>








	</div></div></div>
<div class="chrome_viewport">
<div class="topper_layout_Viewport elliott_layout_Viewport topper_layout_PermalinkViewport viewport-layout grid-fixed"><div class="layout-container grid-2col mainpane"><div class="topper_content_BasePermalink elliott_content_BasePermalink topper_content_MediaPermalink" data-content-id="36988982"><div class="j-article-column c-article-column" 
			data-domain="faminchin" 
			data-post-type="video_post" 
			data-type="n" 
			data-pinned="" 
			data-headline="" 
			data-content-id="36988982"
		>
		<article class="c-icon c-video">
		<header>
			<h1> </h1>

					<div class="j-abuse-reports" data-content-id="36988982">
			<div>Current Status: <span class='j-current-status'>Published (4)</span></div>
			<label>Change Status:</label>
			<select class="j-status-menu" name="statusCodes">
				<option></option>
				<option name="Blessed" value="1">Blessed</option><option name="Published" value="4">Published</option><option name="Unpublished" value="50">Unpublished</option><option name="Restored" value="10">Restored</option><option name="Quarantined" value="40">Quarantined</option><option name="Duplicated" value="30">Duplicated</option><option name="Censored" value="70">Censored</option>			</select>
		</div> 			<div class="c-byline">
				By <a href="https://faminchin.newsvine.com/">Common Sense Mike</a>							</div>
			<div class="c-dateline">Fri Feb 24, 2017 10:33 AM</div>

			<div class="c-tags"><ul><li><a href="/trump" rel="tag">trump</a></li><li><a href="/clinton" rel="tag">clinton</a></li><li><a href="/politics" rel="tag">politics</a></li><li><a href="/obama" rel="tag">obama</a></li><li><a href="/republican" rel="tag">republican</a></li><li><a href="/democrat" rel="tag">democrat</a></li><li><a href="/libertarian" rel="tag">libertarian</a></li></ul></div>

		</header>


	
		<div class="c-article-actions">
			 			</span>
 			 			<a class="j-discuss c-button c-icon c-discuss" href="#discussions" rel="twipsy" data-placement="below" title="See Below">Discuss: <span class="j_social_count" data-verbose="0" ></span></a>
 						<span id="article-vote" class="j_social_count" data-vote-btn="1" data-title-msg="Please login to vote." data-use-button-element="1" data-votes="1" data-content-id="36988982"></span>
			<button id="report-article" class="c-button c-icon c-report j_login_check" data-title-msg="Please login to report a violation" data-plugin="j_report_reportbtn" data-display-name="Common Sense Mike" data-content-type="" data-domain-name="faminchin" data-content-id="36988982" rel="twipsy"  data-placement="below" title="Report this content">!</button>
		</div>

	<div class="elliott_content_ArticleText">	<div class="articleText"><p>People have a lot to learn about Libertarians today. We aren't the fringe crackpots that the media portrays us to be.  </p></div></div><div id="vine-inlineVideo__36988983" class="inlineVideo  photo_align_block inlineYoutubeVideo" data-contentid="36988983"><iframe width="936" height="633" src="https://www.youtube.com/embed/BreSsmqYmPA" frameborder="0" allowfullscreen></iframe><p>Liberty Link Media Group presents Your Daily Headline for February 24, 2017 - Why are Libertarians Such Crackpots - Of all the insults that are hurled our way; fringe/crackpot/conspiracy theorist has to be our favorite. Some of us may be skeptics of big government, but is that crazy? Or are people simply quick to label and dismiss what they don't understand?</p><div class="video_reference" style="display:none;"><a href="http://www.youtube.com/watch?v=BreSsmqYmPA" class="c-button">Watch on YouTube</a></div><!-- end36988983 --></div></article></div>
</div></div><div class="layout-container grid-1col radbar"><div class=" elliott_widget_InsertMPSAd"><div class="box-ad lazy-load" data-placement="staticbox"></div></div></div></div>
<div class="viewport-layout grid-full ">

<div class="layout-container discusspane">
<div class=" topper_content_Discussion">	<div class="content c-discussion-layout">
		<div id="discussions" class="discussions">
			<div class="j-discussion-bar discussion-bar">
				<div class="j-wrapper wrapper">
					<p>	Comments are loading&hellip;</p>
					<div class="coh-block">
						<a href="/_tps/_about/code">Code of Honor</a>
					</div>
				</div>
			</div>
			<div class="j_troff_troff c-widget-troff" data-content-id="36988982" ></div>		</div>
	</div><!-- /  content -->
</div>
</div>

</div>
</div>
</div>
<div class="chrome_footer">
<div class=" topper_footer_Legal">
		<ul>
			<li>&copy; 2005-2017 <a href="http://www.nbcnews.com" rel="twipsy" data-placement="top" title="Newsvine&mdash;a property of NBC News Digital" target="_blank">NBC News Digital</a></li>
			<li><a href="http://www.newsvine.com/_tps/about/newsvine">About Newsvine</a></li>
			<li><a href="http://www.newsvine.com/_tps/about/contact">Contact Us</a></li>
			<li><a href="http://www.newsvine.com/_tps/archive">Archives</a></li>
			<li><a href="http://www.newsvine.com/_tps/about/code">Code of Honor</a></li>
			<li><a href="http://www.newsvine.com/_tps/about/agreement">Terms of Service - UPDATED</a></li>
			<li><a href="http://www.nbcuni.com/privacy/" target="_blank">Privacy Policy</a></li>
		</ul>

</div></div>
<script src="//ssl.nbcnews.com/id/51579771" type="text/javascript"></script><script>_satellite.pageBottom();</script></body></html><!-- cache 1487984434 -->